Choke control springs up/car not start.

Moderator: Moderators

Post Reply
User avatar
Ianep
Found my feet now
Posts: 15
Joined: Fri Oct 09, 2015 11:38 pm

Choke control springs up/car not start.

Post by Ianep » Sun Dec 31, 2017 12:22 am

I am having issues with running car, the car will start ok, and idle ok. But when i stop turn engine off then try and restart it will not start. I have just had a replacement Carburettor fitted.
I notice that when i push the choke control in, it just springs back out.
Could there be a connection between the two.

User avatar
johno
Reliant Geek
Posts: 1201
Joined: Tue Aug 05, 2014 7:57 pm
Location: Sunny Isle of Portland. fully operational

Re: Choke control springs up/car not start.

Post by johno » Sun Dec 31, 2017 1:24 pm

yes, it shouldn't spring back out.
I'm guessing at either the choke cable is routed incorrectly or the jet or choke lever mechanism on the carb has jammed against something. (rocker cover or drip tray maybe)
This would make a rich mixture which is good for a cold start but not so when the engine is warm
2013 Microcar MGO (Bubbles)
1998 Robin LX estate (Bella)
2009 Fiat Panda ECO Active 1.1(Joker)
1984 GL1200 Aspencade/sidecar combi (Beast)
1984 GL1200 Interstate (TopCat)
2012 Royal Enfield B5 Bullet EFI (The Bullet)
2007 Honda NT700VA (Angel)

User avatar
Ianep
Found my feet now
Posts: 15
Joined: Fri Oct 09, 2015 11:38 pm

Re: Choke control springs up/car not start.

Post by Ianep » Sun Dec 31, 2017 7:07 pm

Thanks for your reply, I ran it again today, first it was fine
The control did not jump out, but once the car had warmed up, it started to make the control knob spring out again, would that make sense?

User avatar
acid andy
Reliant Geek
Posts: 590
Joined: Thu Aug 07, 2014 1:17 pm

Re: Choke control springs up/car not start.

Post by acid andy » Sun Dec 31, 2017 10:27 pm

The control knob for the choke should never move on its own - especially never outwards, so the choke lever on the carburetor is pressing against something it shouldn't as johno says or has been wrongly fitted, or the cable is catching on something.

User avatar
Ianep
Found my feet now
Posts: 15
Joined: Fri Oct 09, 2015 11:38 pm

Re: Choke control springs up/car not start.

Post by Ianep » Wed Jan 03, 2018 2:41 am

Update and thanks for help.

With help from someone we took air filter box off, could not find anything wrong, but just taking apart and putting back together seems to have sorted the problem out

Post Reply